Firmware Corrupt/Not Found over and over again

Hi there again!

Couple of weeks back I opened a topic because I had a problem with my MX4 (https://meizufans.eu/forum/topic/3801/couple-of-issues-not-recognised-by-pc-and-stuck-on-system-upgrade-clear-data-page). Sadly, no one replied. Anyway, I’ve tried different computers and finally when I came back from xmas holiday, my PC does recognize the phone :)

I dowloaded the latest stable firmware from the forum, connected the phone with the usb and put update.zip in recovery (PC). After checking firmware and doing the upgrade, it says Firmware Not Found or Firmware Corrupt.

Tried with earlier firmware, nothing. Even tried with 4.0.4A and nothing. Everytime I try to downgrade it, I clear data, but doesn’t seem to work.

If I push vol up + pwr, I get the System Upgrade/Clear Data page.

Any ideas? I’m really out of tricks here…

Thanks in advance!

@Arita all I know is that it’s saying firmware corupt at all I versions of firmwares. Try last stable I version. It should work. Or try first reflash the actual software.

Hi there!

Forgot to mention that my phone is Chinese, so I cannot use “I” firmwares :/ I’m gonna try then to reflash it tonight and see what happens.

Thanks!

Admin

@radumihai it will only return such an error, if you DO NOT own an international device.

@Arita, you do not necessarily need your PC. Simply download the update.zip over your phone and then open the Document app and click on the update.zip.
For more details check the F.A.Q.:
https://meizufans.eu/f-a-q

@Rey Hi there! Thanks for your answer.

The problem with that is that I cannot start the phone. It won’t go further than Upgrade/Clear Data page :/

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.