Meizu MX4 Flyme 5

I need help! First thing i have mx4, international version. I want to upgrade to flyme 5 beta… But i can’t im on 4.5.6I right now and i cant upgrade, i tried downgrading to 4.0.4I and 4.0.4.1I but ibget firmware corrupt… I even tries downgrading to 4.2.8.2I and then to 4.0.4I but still nothing tried so many thing and always firmware corrupt i want this update badly, so if someone has a solution please tell me, thanks in advance!

@JamesStark tick clear data, not only system upgrade

@JamesStark try updating via recovery mode (press and hold volume up and then the power button). Also make sure the update.zip is not damaged by checking and verifying the MD5 value.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.