Root not working ob m2 Note

My m2 note is running on 4.5.4.2 International firmware,today i obtained root privilege through flyme account but even after this,root is not working like it supposed to work. Anyone on same boat?
.
.I confirmed it by using various root checker applications as well as some root required apps which works fine on my other rooted phone.
.
.what is the issue, anybody? 😕😢

Contributor

@pratikdeshmukh1 You could try to update + clear data and root again.

That’s the only solution, I can think of.

Like flashing whole firmware again to revoke root permission and then again obtaining it?

Contributor

@pratikdeshmukh1 That’s what I would try. It’s simple and doesn’t need more thinking.
But at the same time it’s inconvenient.

Btw. What exactly did you do? Do you have SuperSu installed?

OK.
.
Initially I didn’t installed it but later I thought it’s worth trying but even that didn’t helped me.it didn’t proceed ahead of su binary update screen 😕

@Ultrametric Hi. I have a Meizu M2 Note with 4.5.4U firmware. When i received the device was rooted because when i installed kingroot for example it didn’t go through any rooted process because it was already rooted. I did a factory reset and from now on i cant root the phone. I have a flyme account and the system privileges are open. I allowed kingroot access but it can’t root, tried also with supersu but nothing. I don’t if it is because of the firmware which i can’t changed (based on an article i found) because the phone isn’t rooted. Your help would be much appreciated.

Thank you in advance.

Contributor

@moriarty Try to update + clear data.

And switch to the “A” firmware or the “I” firmware, after converting your phone to a global one.

@Ultrametric I cannot update it cause there is no U update plus i cannot switch to another firmware cause it needs root access which i dont have. If i had root access i would follow the guide in the forum regarding on switching to another firmware. I have factory reset the device countless times but still cant root. I searched on google but nothing helpfull regarding my situation. PLEASE HELP ME.

Contributor

@moriarty You don’t need a U firmware :P

Just download the latest “A” firmware and update from the Recovery.

Yes, factory reset is not the solution to your problem. But update + clear data is it.

Just read the F.A.Q. and update to “A”. Please do this and ask if you run into further trouble.

@Ultrametric I copied the update.zip file to recovery but it says firmware corrupt. Also in the F.A.Q. the update files are .bin not .zip. Flyme site provides only .zip file. I don’t know if this has to do with this. Please advise.

Contributor

@moriarty what’s the precise name of the firmware you downloaded?

You can install the public Chinese firmware. The U firmware is just a carrier branded version of the “A” (what’s the public chinese.)

@Ultrametric The firmwares name is 4.5.4.2 I. Could you send me a decent link to download a firmware that you think it will work or a method to install it?

@moriarty I figured everything out. Should i post here the solution or create another post?

@Ultrametric First of all for everyone with a U firmware ONLY an A firmware can work for a downgrade. I used 4.5.4 A with recovery and it worked. Then i tried changind the ID using the article in the forum cause its the only that after flashing the rom can support OTA update.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.