Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

  • Push Notification Issues with WhatsApp and Threema


    Hello MEIZUfans,

    I have an issue with push notifications from WhatsApp and Threema. Both are instant messenger. The Problem is, that I dont receive any messages with both of them, until I enter the app manually and wait a few seconds.

    If I chat with a person via one of those apps, go to the home screen afterwards and lock the device (turn the screen off, fingerprint activation is set), I can get a notification if someone writes to me (for maybe 1 min after I exited the messenger app and locked the device ).

    If I switch from “WLAN” to “Mobile data” and vice versa I receive all new messages .

    I receive push notifications from the “Facebook” app and the “K-9 Mail” (an email client I installed manually) app.

    I havent got this problem from the beginning on my MX5. I have it for about 6 month and the problem occured around a month ago. I’m fairly sure (but not to 100%) that there wasnt a system update in that time.

    My Flyme Version is 5.1.1.0A (received via the Flyme Updater).

    I tried the following things to solve the issue:
    -I googled :) but to no avail :(
    -I checked for “Security->Permissions->AutoRun Managerment”; both are activated
    -I checked for “Security->Permissions->Notification Managerment”; both are activated
    -I checked for “Security->Power->App management”; both are activated
    -I checked for “Settings->Permissions->Notification and status bar->Notifications management”; both are set on “allow notification”
    -I locked both apps in the “Task Manager”
    -I deinstalled both apps; did a restart; installed both apps

    What I havent done till now is a wipe of the phone (and hope I dont have to do it :| )

  • Hello,

    Same issue on mx4 pro, flyme 5.5.12.29.

    Someone said if we freeze the security app, push notifications will work again but i didn’t tested.

  • I’m experiencing the same issue (Whatsapp) with my MX-5. I tried all you did, I also installed an app, “Push Notification Fixer” but it continues.

  • It seems to be a common issue with Flyme 5. I also have the same problems.

    Meizufans on Facebook
    Meizufans on Twitter
    Meizufans on Google+
    READ THE WIKI FIRST!!!

  • I have that problem too. Tried to even disable Security app, doesn´t work.

  • @ccomatoseh How did you disable it?

    Xiaomi Mi5 Basic

  • It seems to be solved.

    Finally I was able to install latest “I” version onto my “A” phone, by changing phone ID. I think A version doesn’t like the apps downloaded from Play Store and kill their background services.
    You may try to download Whatsapp (or other apps) from Flyme App Store.

    Since I downgraded from 5.xx to 4.xx, I’m not having delayed notification issues but I lost an important feature, when phone is in sleep mode, incoming Whatsapp messages doesn’t light up the screen. Annoying

  • Good Morning,

    I had exactly the same problem since Flyme version 4.5.7A. I have completely solved the problem in my Meizu m1 note doing the following:

    In Security APP (include in Flyme OS):

    Permissions; Notification Management -> Google Services: ON (only verify, is normal status, I think)
    Permissions: Autorun Management -> Google Services: ON (only verify, is normal status, I think)
    Power: App Management -> Google Services: ON (very important, I think)

    Afer this, install app from Google Play called PNF No-root (search Push Notifications Fixer). It’s free.

    And that is all!!. In my case, working since version 4.5.7A from actually version in my case (Flyme 5.6.1.5 beta). Push notifications in Whatsapp, mail’s app’s (meizu, mailwise,…) is working perfectly,…

    Note: Idea partially extracted from the support pages of Whatsapp. In this page, reference to another application (DNSet) that I did not need to be installed but you can use it if does not solve your problem becomes.

    I hope you help,…

  • This post is deleted!
  • @Golum said:

    Good Morning,

    I had exactly the same problem since Flyme version 4.5.7A. I have completely solved the problem in my Meizu m1 note doing the following:

    In Security APP (include in Flyme OS):

    Permissions; Notification Management -> Google Services: ON (only verify, is normal status, I think)
    Permissions: Autorun Management -> Google Services: ON (only verify, is normal status, I think)
    Power: App Management -> Google Services: ON (very important, I think)

    Afer this, install app from Google Play called PNF No-root (search Push Notifications Fixer). It’s free.

    And that is all!!. In my case, working since version 4.5.7A from actually version in my case (Flyme 5.6.1.5 beta). Push notifications in Whatsapp, mail’s app’s (meizu, mailwise,…) is working perfectly,…

    Note: Idea partially extracted from the support pages of Whatsapp. In this page, reference to another application (DNSet) that I did not need to be installed but you can use it if does not solve your problem becomes.

    I hope you help,…

    Thank you very much, This Worked for me!!, it solved a really anoying problem. I Have a Meizu PRO 5 with flyme 4.5.7A and Whatsapp downloaded from Google play store., I followed all the steps, I don´t know what solved the proble or if it was all together.

  • I think till now you have solve your issue and used whatsapp freely and receive and send massages on it so select best Status for Whatsapp and send to all.

    Top 5 Bulk SMS Service Provider in India with SMS API

Posts 11Views 7824
Log in to reply

Looks like your connection to Push Notification Issues with WhatsApp and Threema was lost, please wait while we try to reconnect.