Reinstall Play Store

I have Chinese Meizu m2 note and new Flyme OS 4.5.4.2A and everything worked fine on my phone BUT I DELETE google play services in the security center. Now if i want to install Google Installer I don’t have google play services on my phone. If i try to install anything that needs google services I get the message “You don’t have google services in your phone, contact your manufacturer!” I tried to downgrade version and i did it, but the problem is still there.

How to get back google services on my phone? Thanks!

last edited by Ultrametric

@pinklec123

I think I deleted google services,apk in security center. And now i can’t get it back. I tried to download the apk from apkmirror site, but I get the icon with google setings but it want work.

last edited by pinklec123
Contributor

did you try the google-installer? from the f.a.q.

Will adjust the topic title. Less is More!

I tried everything that i found on the web. And when want to install Google Installer if want install it like the the first time when it worked fine. It just stands and say installing and that’s it. And if you go back, and than click on icon Google Installer there is a red ! mark on Use Google Services, and in the corner say Fail.

last edited by pinklec123
Contributor

@pinklec123 I had the same problem. And resolved it on my MX5… by restoring from the Flyme Cloud, I had a backup there.

You can either try to restore from the Flyme Cloud, or install it yourself.

That’s what works on the MX5:
Play services: https://www.apkmirror.com/apk/google-inc/google-play-services/google-play-services-8-4-89-2428711-248-android-apk-download/
Play Store: https://www.apkmirror.com/apk/google-inc/google-play-store/google-play-store-6-0-5-android-apk-download/

So once again: start google-installer, let it install some stuff… and then try the play services and newest play store.

It could be that the here linked Play services don’t match your phone… but that’s no issue, just search on apkmirror for the one you need.

I can’t make the Flyme Cloud acount.

Contributor

@pinklec123 did you try the 2nd method, stated in my last post?

I tryed and i got icon of Play Store, but something is wrong. I don’t know what version of google services and Store to install for my phone. I will try again when I get home on WiFi. Thanks!

Android version: 5.1
Flyme OS 4.5.42A
Baseband version MOLY.LR9.W1444.MD.LWTG.CMCC.MP.V9.P30, 2015/09/15.

last edited by pinklec123

@Ultrametric Had the same problem with my Pro 5 and those two links fixed everything. Thanks!

I install the Google Installer and those two…Play services and Play store and got some progress…i accessed Google Play and log in but now the problem is when I try to download something it tells…server error… Probably the version of Google play or Play services is not correct.

And i don’t know what version to install for my phone. Android version 5.1,
Flyme OS 4.5.4.2A

This is from Meizu help center: Thanks for supporting MEIZU.
We are deeply sorry that it was not work on your device.
Sorry that we don’t make sure whether it is firmware or hardware problem.
Please kindly wait patiently and hope our future firmware will solve your problem.

Thank you and have a nice day.

Can someone check and wrote me what version is on his/her phone so I can try to install that version!? Thanks!

Again: Android version 5.1,
Flyme OS 4.5.4.2A

I don’t know if serial number of the phone means anything for that!

last edited by pinklec123
Contributor

@pinklec123 Google for the error message. Or write it down ad share it here.

I solved the problem yesterday. I delete everything from google… Reboot my phone and downloaded Google Installer once more and the same problem was there.!

Than I delete the google account that was log in in the Google Play Store and log in with another google email that I have. Than everything worked fine and I was able to download everything from Google Play. Next I refreshed my old email on Google and log again with that email. Now it works fine whit the old email.
Than’s for your help!

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.