Flyme 5 for the M2

Hey folks!
Since Meizu is not fixing the buggy security app on Flyme 4.5: any news on Flyme 5 for the little m2??
Greetings!

Contributor

@wegwolv After February 2016, that’s all we know.

@Ultrametric said:

@wegwolv After February 2016, that’s all we know.

Thanks for the Information!! :)

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.