Got a brick during update

Hello, Meizufans!

Once-upon-a-time I have tried to update my MX4 to the Flyme 5. Before that I had done clearing data from system settings (as it described in instruction) . By clicking “update.zip” I have begun updating.

Device is bricked now. I can’t access system or recovery mode. The only mode I can use is fastboot.
After reading tons of posts I couldn’t find distinct instruction about how to get recovery mode back to my phone.

Please, help me to bring my phone to the life.

last edited by igorbvik
Contributor

@igorbvik Did you unlock your device?

How did you update to Flyme 5?

Please describe what you did, and be very detailed about it :)

Well of you can access fastboot all you need to do is flash original recovery using it.

  1. get fastboot drivers and make sure they work
  2. Get mx4 firmware update.zip on pc, extract it and find 'recovery-uboot.img’
    3.Place this file into the same folder as your fastboot.exe (in fastboot drivers folder)
    4.Boot your phone into fastboot( power and volume- you should only see lit black screen.
    5.Connect phone to pc
    Launch fastboot and flash recovery with this command

fastboot flash recovery recovery-uboot.img

Or there is a guide on this forum which also does it using flash tools

Meizu MX4

@Dysync mmmmm uboot.img is lk… xD bad idea flash it from faboot

@Ultrametric I have tried to get recovery by fastboot. The result is security error. It’s about buying new phone. I think question is done.

last edited by igorbvik
Meizu MX4

Sorry sir , you have unlocked the phone first of install flyme 5?

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.