Google Play Store doesn't work!

Hi all,

I just got the Pro 5, installed the Google Installer which then installed the google sevices and the play store. The play store opens and I can log in. But when I would like to download some app, I get an error message with some error code.
I tried to reinstall, delete the app/cache data but it didn’t help. I also tried to factory reset the phone twice and reinstalled the gapps using google installer (always from the meizu store btw).

Does anyone know how to avoid the error message?

I use the standard “public version” of the Pro5, bought in China.

Please help, otherwise I need to give it back. I really need the google app store…

Thanks and merry christmas!

Admin

@Jan219 which installer you used?
I just added version 2.0.3 to our F.A.Q.:
https://meizufans.eu/f-a-q

Also, which firmware you are using?
Flyme 5.1.1.0A?

By the way, try to clear the data of the Play Store App and Services.

last edited by Rey

It worked now. Just reinstalled the Installer from your link (which was actually the same version) and restarted the phone.

Thanks a lot!

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.