Flyme OS 4.5.7.1 stable (MX3)
Admin

Changelog:
Repair items

  • FIX: Contacts are likely to be abnormal remove the problem.
  • Fix: Even now call prompts “This user does not have to dial a non-emergency service calls” problem.
  • FIX: connection has been connected before the Wi-Fi issues need to re-enter the password again.
  • Fix: make Internet phone calls in the mobile 3G network prompt “native network anomaly” problem.

Download:
Flyme 4.5.7.1A

Source:
Flyme 4.5.7.1A

Hello and thank for uploading.

Are the changes in the changelog the only changes have been made?

Can someone try it and check if it’s lag free and if it’s relied on android 5.1 ?

has anybody tried this??

@Rey I dont know how to start new post, so <i writing my questions here.

I have tried many of Flyme upgrades to my MX3 intl. pphone but always got answer “Firmware corrupted”. No matter from what sources i got it. Any help???

Thx in advance

Admin

@Beqq you may only open a post in the Q&A section.

The issue you are ecountering is that your phone simply is no international device and you therefore are only able to flash A firmwares.
But as you say it is one, I suppose you bought it from a local stole and therefore have the TCCM version.

Check this guide then:
https://meizufans.eu/forum/topic/1402/tutorial-upgrading-tccm-o2-devices-to-flymeos-4-1-3-5i-and-up-the-unofficial-way

After I’ve updated. My homescreen doesn’t work. however it has light, when I touch it it doesn’t show a sign of life. no back function, no lock function…

anybody can help?

Why can’t I upgrade to Flyme OS 4.5.x? “Firmware Corrupt” Everytime :( pls help

@ Adamço: you should try to download from a different link, with a different browser or on a different machine, disabling your antivirus.

I am testing this rom right now (just upgraded from 4.2.8.2I) and so far so good :) I’ll post in a while about it!

Everytime I tried to up/downgrade through “ordinary” way it failed. Once, one good guy sent me “special” installer and I succesfully downgrade to Flyme OS 3.5, then I uprgraded back to Flyme OS 4.2.8.1O also through installer and it worked, but everytime I tried some other firmwares (ordinary way) - firmware corrupt… Is there an ‘installer’ for this firmware?

Admin

@Adamčo as you might noticed yourself, you are using a different “device type”. The so called O firmwares are from TCCM and include a bootloader lock, which only allows to flash O firmwares.

If you want to get pass it, you have to unlock your device. The correct guide can be found in the Rooting & Modding section.

I’ve tried it, but sth went wrong… I will try it one more time, hope succes

can i use Xposed installer on this version??

@Rey can u link me tutorial that works for you?

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.