Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

SIM Tool Kit APP

0

Hi everyone,

I am using SIM tool kit application for mobile confirmations. Application is placed here: “/system/app/Stk/stk.apk”.
It was working on Flyme 5.1.1.0A. Now I’m on Flyme 4.5.4.2I (updated from A) and it does not work. Window asking confirmation just pops out, I press OK and nothing happens (it should ask me for SIM PIN code). Like this:
0_1450089890619_wWtbIq5.jpg

Does anyone knows workaround?
Maybe someone could share Stk.apk (extracted from phone) from A version (5.1.1.0A or 4.5…A)?

0

@simsunas did you clear data when you downgraded?

Xiaomi Mi5 Basic

0

Yes, twice.
Tried to remove Stk.apk, clear leftover data, reboot, add again and still same…
It looks like after pressing OK, app is running in background. If I try to get receive confirmation message again - nothing happens until I reboot phone itself :(

0

Hello, did you find the solution guys? Same happening with latest global build, it was working with Flyme 4.5.7I

0

After upgrading to version >5 it is working like this:

  • Approval request appears
  • Pressing OK
  • sPIN code enter window opens
  • Reboot phone to make it work again :laughing:

Haven’t tried to do factory reset though.
Also, I have to mention that everything worked with Chinese version…

0

i have the same problem…you can enter sPIN only once, then you have to reboot again to enter again…

0
This post is deleted!
0

Guys, any update on this? I have issues with my M5 note… It only lets you to enter it once…

0

Nope, Flyme still sucks...

0

Just installed 6.7.3.14 A beta version and SIM toolkit is working fine!

I could suggest to extract it from there and try to paste in stable version.

Tried to attach here but could not do it, so here's a link to it: http://www.mediafire.com/file/...

0

And how to extract it in to the phone without a root? any suggestions?

0

Just enable root :)

0

I am on waranty. Do not want to go that mad :D

0

Maybe just update the phone to latest version or beta through recovery and clearing data.

ZHENK

Log in to reply

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.