[HELP]I want to downgrade my Flyme OS

Hello, i want to change my flyme os ( i want to downgrade ) , when i put the update.zip, it give me error corrupted file can you help me please ? i have MX5 , version A

@iMoDz try to download it again…

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.