[Tutorial] Listen the music on your hifi DAC and headphone amplifier everywhere (LOLLIPOP FLYME ONLY)
Meizu MX4 Pro

So, whats the problem? I can tell you, some of us bought mx4 pro as music device because of high fidelity DAC from sabre - which is Sabre ES9018, and headphone amplifier from texas instruments - which is OPA1612 opamp. So it’s really good device if combined with pair of good headphones. Problem starts when you are using music streaming service, like spotify and tidal for example, or some third party apps like poweramp. And here are 2 kinds of people:

  • You may noticed, that music quality and power on headphones is significantly deacreased on those, compared to stock music player.
    Thats because hifi feature is disabled on those apps, you are not using your sabre and amplifier anymore. There are some apps that can use hifi components on stock (besides flyme music player), like ttpod for example, but not too many. It’s probably set that way, because sabre+opamp drains more battery, but not much more i can say.

  • You are listening on earphones which doesn’t need too much amplification, and you didn’t noticed any difference. It does not mean you are deaf. Because as a alternative meizu is using wolfson wm8998 which is also very good dac - so sound quality is still amazing, and your earphones are driven correctly - so you don’t hear any lack of punch or something. But even there, you could noticed that hifi feature on phone settings doesn’t work at all. There is no difference if you change gain from low to high, or line out.

HIFI on kitkat works everywhere so there is no need to change anything,
but how do i enable it on lollipop? In any app that i want? —>

OFC you need to have root, and some root explorer.

  1. Go to system -> etc -> audio_hifi.conf. Open it with text editor.

  2. Here is your list, you just need to add your app on the list. You can find full names of apps in data -> app.
    for example, spotify line should look that way: package com.spotify.music
    photo: https://i.imgur.com/glCrFe5.jpg

  3. Save and make sure that permissions of that file are 0664 (rw–r–r). If not, make them right.

  4. Reboot your phone.

  5. Enjoy.

last edited by n3roxe

@n3roxe Thank you very much !
I didn’t notice it until you post this…
But now I tried it I hear adifférence on spotify !

there is no audio_hifi.conf to me.only audio effects

Meizu MX4 Pro

audio hi fi should be right after audio effects, which version of software are you using?

I’m on 4.5.7 and i was using Root Browser from google play.

ok .i went back to 4.2.8. maybe that’s the reason

If you want to know if audio hifi works with your software, you can try to modify the hifi options in settings. If Nothing changes, then hifi audio is not activated.

Meizu MX4 Pro

I know why, coz i downgroaded my firmware to kitkat (i honestly recommend it tho, that soft is just better, faster and more stable).

In older kitkat roms, there is no hifi config file, because hifi works everywhere. That simple :)

Hello, do you know if this procedure works on flyme 5 beta for mx4 Pro?

New owner of mx 4 pro. Music quality is very good for a mobile phone.
Native dac I think supports 24/96 files, but they are downsampled to 48 .
I made the test with usb audio player pro without dac.
the same test I made for my other phone lg gflex 2 that can play natively 24/96 files .
when I connect an external dac like fiio e17 24/96 files can be played correctly.
is there a tweak for enabling native 24/96 playback for our mx 4 pro?

Now I’m confused. I use Flyme 4.5.6A version and Shuttle+ Music Player with no other settings edited for FLAC/WV/MP3. Do I need to somehow enable this hifi DAC? Shall I use other Android Music Player?

Is it working on firmware?

Meizu MX4 Pro

@samson09 said:

Is it working on firmware?

In the stable Version i look in the HifiConfig and all Apps was in the list PlayMusic Deezer Spotify and so on.

Meizu MX4 Pro

@kutulu32 I’ve tried smsl m2 5th anniversary and it doesn’t work at all. While it works beautifully on xperia Z2.

@Fanax Probably, if gains in settings of the phone doesn’t work.

@samson09 Flyme 5 doesn’t need that tweak because its already implemented.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.