[How to Fix] Error retrieving information from server [RPC S-7 AEC-7] [RPC S-5 AEC-0]

Hello :)

I own a Meizu MX5 by a week, and I can use it only from 2 days because before it was locked with another FlyMe account (probably of the Quality Control service of the shop where I bought it).

Today I’ve tried to install the Google Installer in order to get the Play Store. But whenever I try to download an app from the Play Store I get this error:
App name can’t be downloaded. Try again, and if the problem continues, get help troubleshooting. (Error retrieving information from server. [RPC:S-7:AEC-7 code of 12 characters that changes for every app]”

I’ve already tried to search on Google about this problem, but I haven’t found a guide that solved my problem.
To be clear I have the 5.0.0.1A version of FlyMe.

Could anyone help me please?
Thank you in advance.

last edited by Ultrametric
Contributor

@Molmark It’s a known problem.
If you use the search function (for the future) you may find a solution here.

Anyway, if the store you bought the phone from messed around with it, re-update the firmware and clear data. Who knows what they did with the phone!

Edit:re-update + clear data, probably wont solve, try the other approach.
When I had the problem, re-update + clear data solved it, but you can also try the way that google tells you. As the problem is not related to Meizu/Flyme.

By stopping the google servies, clearing data of the google services, logging out your google account(s) and restarting the phone. (Order may be mixed up).

Youtube video:
https://www.youtube.com/watch?v=rheZfmMI5XU
It may look different as flyme looks different, but is the same principle.

Edit: Fixed the title of your topic, maybe we should tag this topic :) as quite a lot of people ask for it.

last edited by Ultrametric

So fast replying c:

Thank you for the help - I’m trying to re-update + clear data, I’ll let you know.

Ok, so - After the re-update + clear data, the problem still persists.

To find the problem I’ve logged out from my main account, I’ve deleted Google datas and I’ve tried to use a different Google account and… it worked! I could download apps normally.
But I needed to use my main account, and not a secondary one. So I just logged out from the second one and re-logged with the main, and after a reboot now it works ^^

when i upgrade my meizu mx5 to flyme 5.1.1
these error comes always when i download apps and many error like these comes
0_1449990776497_S51213-123518[1].jpg

I had this error today on 5.1.1.1A thanks for the info.
I installed the “Google Install” app from the App Store.

So here’s a simplified method of what worked for me;

  1. Android Settings > Other Account > | three dots top right > Remove Account
  2. Apps > [Google Play Store | Google play Services | Downloader] > Clear Data / Cache
  3. Android Settings > Other Account > re-add Google account

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.