Downloading won't work on app store or browser

Hello!
I just got my m2 note from gearbest and it has a google app store but it starts to download but nothing ever gets downloaded. Also I’ve tried to download a firmware update zip file but it doesn’t download either. Don’t have a meizu app store on the phone and “download app” (or what you call that) says download downloading service disabled. Please help.

Contributor

@poikatiikeri

have a look at the F.A.Q. and reflash the newest Firmware “A” with clearing all data.

Who knows what gearbest did with your Chinese phone, simple reflash the firmware should bring you back to stock Flyme.

You don’t have to download the update.zip from your phone! It just has to end up there.

last edited by Ultrametric

Sorry I don’t know what thread i should be looking for. Tried to find this reflash firmware “A” but don’t find one. Tried factory reset and doesn’t help.

Contributor

Link to firmwares: https://meizufans.eu/firmwares/
or here: https://meizufans.eu/forum/topic/2878/flyme-os-4-5-4-stable-m2-note/2

And factory reset might not help, because gearbest did who knows what do your phone.
Just re-update and clear data.

Read the F.A.Q, can be found in my signature. Use the 2nd method to update. And firmware “A” is a firmware that end with the letter “A”.

last edited by Ultrametric

@Ultrametric I now have the update folder on my root directory but can’t get to recovery mode by shutting down and then starting the device with volume up button + power button. It just goes on normally…

Contributor

@poikatiikeri are you holding the power button + volume up?

If you can’t access your Recovery Mode that way, open a paypal dispute. As gearbest didn’t sent you a Meizu phone.

last edited by Ultrametric

@Ultrametric I finally after 20times got it to work and managed thanks to you to get a new version of flyme! But now i downloaded the google installer and play store and get an error message when trying to download whatsapp : (Error retrieving information from server. [RPC:S-7:AEC-7 5NXI-OSWS-W2SM6])

Contributor

@poikatiikeri I had that message too, there are different way’s to solve it.

The way I solved it was re-flashing the firmware and selecting “clear all data”.

When you updated, did you click on “clear data”? If not this may have caused the problem.

You could either flash the firmware again and clear data, this time.
Or try a different approach by stopping google services, clearing cache from google services, and logging out of your google account. It’s a common problem, and has nothing to do with Flyme or Meizu. Just google the error message.

@Ultrametric Thank you so much! I did clear the data but still gave me the error. I did the clearing cache and deleted my google account and restarted the phone and now it works! Thanks so much, you’ve been amazing help!

I was just having this exact problem as well. I believe there was a location permission that needed to be granted, but wasn’t being asked for. Opening the Play Store, then going into the settings of it, then either People or My account triggered the permission to be asked for. This seemed to fix the problem for me.

Hello guys, exactly the same happened to me @poikatiikeri. After reflashing the firmware, because I was not able to download nothing from Google Store, I also got an error message (the same one as you). Following @Ultrametric instructions, I was finally able to download normally apps from Google store. Thank very much guys for your enormous help!!

I installed 4.5.3A firmware. Do you know something about 4.5.4.1I update? Is it worth installing??

Thank you once more!!

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.