Firmware update caused google play to not work

Yesterday I camed acrossed this forum and saw this 5.0A update so I updated
Everything was perfect but when I went to google play it did not work
The error was “Authentication is required”
I tried many solutions
Nothing worked so I ended up deleting it
Since then I couldnt restore it
Tried many APK’s
I even did factory reset and nope…

Guys I really need your help cause I basically cant log in my google account to sync the backup
How do I get it to work…
Right now with the APK its stuck on the loading…

Contributor

@idanc99 Just install it through the Meizu AppCenter. search for the “google installer” app.

I don’t know what you did to your phone, so maybe you should reflash the firmware and clear data at the same time.

Works.Thanks! But now theres an error with downloading any app…

last edited by idanc99

i am also faving the same problew . While i am downloading any app from play store there appears an error saying error retreiving information from server . Plz help

Contributor

@laxmanS for Gods sake make your own topic! I told you so, wtf are you doing! Anyway, too late now.

@idanc99 if you have an error, state your error. There is more than just one error message out in the world. And so there is more than one solution to an “error”!

If you guys are facing an error called Error retrieving information from server [RPC S-7 AEC-7] [RPC S-5 AEC-0].
After typing the error into google, I found this video: https://www.youtube.com/watch?v=1IujFpuP3NE

Google is quite powerful and cool, try it. Hope this fixes your problem. If it doesn’t please state your error message, after you did a google research on it.

I actually had the same error once, after I did an restore my home-screen from the Flyme account. Though I just solved it by not restoring from the flyme account, what’s not a solution to it.

Anyway, sometimes just restarting the phone several times might work. Try, it too.

last edited by Ultrametric

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.