Stuck at logo MEIZU...bis

Hi
Same problem that gudell…fix on logo Meizu
but I can get recovery…
Two days ago, after starting, the device displayed a permanent logo Meizu…no more.
Holding button up + power, I can access at recovery ( pic 1)

pic_1.jpg
Connecting with my PC , in folder recovery I can put an upgrade
but after starting if it’s an upgrade firmware A… I have message '” File not found” ( pic 2 )

pic_2.jpg
and if it’s an upgrade firmware I… it’s the message “ File corrupt” (pic 3).

pic_3.jpg
After starting the upgrade file disappears from the recovery folder of my PC …I don’t know if it’s normal.
Any idea ? Maybe a special upgrade file to put in the recovery folder ?
Thanks for help.

Contributor

@zorax Hey :)

What was the latest Firmware you had running, and what Firmware are you trying to flash. Do you have a Chinese Version of the MX5?

just try another firmware it will work. you cannot flash I firmware like that so try A or C
and yes its normal because the phone refuses that firmware and deletes it so you can place another (good) one
try redownloading the firmware,maybe its corrupt.

last edited by SeaMoose

The latest firmware I have tried to flash is 4.5.4.1 I
doing the method 2 here https://meizufans.eu/forum/topic/2599/guide-how-to-install-i-international-firmware-on-your-chinese-mainland-meizu
unfortunately the installation had failed and now I am in this situation

Contributor

@zorax do just like @SeaMoose said and flash firmware A.

Thanks Ultrametric
but as said above I have the message “File not found” with firmware A

Contributor

@zorax At what point did the installation fail?

And what Version did you run, before you tried to flash the International one onto your Chinese Phone?

Try to flash the following firmware: 4.5.2.7A , and give feedback if it works please.

last edited by Ultrametric

I followed the way described in method 2 and I have waited for a hour the end of process but nothing was happening !!!
So I rebooted and after I have had the stuck permanent logo Meizu.
With firmware 4.5.2.7 A I have the message “File not found”

Contributor

@zorax So you turn off your device, you press Voume UP + Power Button until you are in the Recovery mode.

Then you connect your Phone to the PC, a “recovery drive” shows up, on this recovery drive you copy/paste the Firmware. Now you safely remove the device and apply the update on the phone.

Is this exactly what you did?

Edit: If you are using Linux, open a terminal after you unmounted the drive and type: $ sync

last edited by Ultrametric

can you please try redownloading the firmware…? happened to me aswell and the download was bad.

I’m using Windows.
I have put 4.5.2.7 A in recovery folder then removed the device
but after applying the update I have the message “Firmware not found”…very strange

Contributor

@zorax try what @SeaMoose said, and maybe try different versions.

You aren’t the only one that could not install the new international firmware, but one of the few who has trouble flashing a different firmware now :( .

I wonder if Meizu broke the “hack”, and we have to find a new version to get the International Firmware to a Chinese phone.

last edited by Ultrametric

Thanks for your help
I’m going to return the device for repairing
I hope it’s possible but I don’t believe I’ll take again a Meizu
It’s too difficult to follow the development on the european market

last edited by zorax
Contributor

@zorax Edit, let me fix the grammar!

" Are you able to give your device back? Usually it’s hard to get a device repaired, outside of China."

last edited by Ultrametric

I don’t understand your question ?
What’s back device back ?

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.