Google Play Store Problem

Hi all,

I have received my Pro 5 today which I was so happy about as an owner of the MX4 Pro as well.

Trouble is installing the Google Installer from the App Store (Meizu) installs successfully but when trying to download anything from the Google Play Store once installed all fail to download/install.

Anyone else using the Pro 5 and getting the same thing? UK user here.

Cheers,

Antz

last edited by Kokkie

Do you tried to manually update Google Services ?

Hi thanks for the reply.

I found out what the problem was and it was very common with the MX4 Pro to and I forgot about it! lol

When receiving an OTA for a new update it is best to factory reset the MEIZU for a more stable OS plus helps with the problem I just had :-)

Moved from 4.5.4A to 4.5.4.1A and did a factory reset and wipe data/cache and now all working fine :-)

Contributor

@Leddra2k How’s the Pro 5? Is it a worthy upgrade, what do you like about it :) share your impression please.

Contributor

he got it just today )) i guess we can ask those questions in a month…
im more interested in next phone they will release… i mean next Pro phone… as i think thats where we will see worthy things under the hood

Contributor

@Latstyle agree with you there :)

Yes I have my Pro 5 today 😀 I will run some test with it then leave a little a review of my findings coming from owning almost every phone on the market and testing there limits. The Meizu MX4 Pro I have as well was chosen because of my ear for detail when listening to music on the go! I have a list of other phones I’ve tested over @ Headfi.org if into your music 🎶.

Short sweet first impressions of my afternoon with the Pro 5…

If you love the iPhone6/s Plus and itsits beautiful hardware design but want android then the Pro 5 is right up your street! 😀 The flyme OS I’ve found more stable from my first experiences with my MX4 Pro.

I will return in a couple of days once I’ve tested it some more, performance, audio quality, battery life etc etc.

Cheers

Antz

Congrats Bro! At where did you buy it can you tell me the price ? Thanks …

Contributor

@err0r Kimovil is always a good page to check the price of a Chinese Phone.

http://www.kimovil.com/en/compare-smartphone-prices?search=meizu pro 5

oppomart has it too for about 499$ without shipping.

last edited by Ultrametric

I got mine last week (64GB version), it was preinstalled with Flyme 4.5 and Google Play, but it was kind of buggy and I filled it with more junk (removed Chinese content and tried to install Xposed but nothing happened). Installed the latest test firmware and now works flawless even managed to install Google Play. Here is how I did it:

  1. Downloaded update.zip with the latest firmware and installed it from its built-in recovery (VOL UP + PWR)
  2. I had made Meizu account so I can root and unroot my device (it’s convenient).
  3. Downloaded Google Installer from its built-in Chinese App Store.
  4. Logged my Google account but PlayStore didn’t show me any content and after that it couldn’t install any app. Tried clearing PlayStore cache and data from the app manager in the settings, nothing happened (both Wi-Fi and data connection).
  5. Activated Install Apps from other sources in the security settings (this maybe is the solution) and now it flies
  6. Reactivated root from Security Settings (its been moved compared to Flyme 4.5). This is user dependent, I like full access and use some apps that need root privileges.

Mod Note: adjusted topic title.

I had this problem. Tried two different firmware versions but still had the issue of apps from Google Play Store not downloading even after installing the Google Installer from the Meizu app store.

What you need to do is (and its gonna sound silly but it works) open settings, go to the languge and time section, turn OFF automatic time setting and change both time and date MANUALLY to the wrong time and date and close settings. Now go back to the language and time section and change the time to the correct time and date then turn the automatic time setting back on.

Seriously, it works.

Yesterday, I was foolish enough to do a factory reset on my Pro 5 … Of course, the phone than booted up with a bunch of Chinese software and without Play Services. I tried with
(1) Google Installer,
(2) by installing Google Play Services and an app with a Play Store icon,
(3) I changed the system time,
(4) downgrading to older firmware (5.1.1 and also 4.5.x) and doing all of the above,
(5) and some of the above combinations I tried with root access enabled and without root

Nothing worked. Any suggestions on what I’m doing wrong?

Thanks,
Marko

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.