Help about my Meizu M1 Note

The image below is the Details about my phone. After upgrading it to 5.1 using upgrade botton on my homepage.


After upgrading… I notice that i can’t change my network to 3G and 2G… Plus for some reason in the image below it’s 4G that was selected and when i open my Packet Data I only recieve a 2G network. Why is that?

TMPDOODLE1445775919459.jpg !

Please help me… Thank you in advance.

last edited by Patrick Paul Pajo Ocampo

@Patrick-Paul-Pajo-Ocampo That’s hard to say, check with your provider what bands 4G uses at your location, and compare it to the supported bands of the phone. As well be aware that one Sim Slot is 4G and the other one only 2G.

@Ultrametric Any simcard in my country can switch to 4G, 3G, 2G, My only question is when i tried to select the 3G or 2G it can’t change… Is that a bug?


@Patrick-Paul-Pajo-Ocampo Your sim card operate on bands, did you know this?
And did you check that your phone supports the bands of your sim-card provider?

If that’s not your problem, please explain better what you mean.

last edited by Ultrametric

yes… In my previous Firmware I can freely select 2G, 3G, 4G… But when i upgraded it to 5.1 I can’t select it what i want…


I have no idea what you want. Someone else has to help you, wait for it.

@Ultrametric BTW. I just posted my Phone Details :3


Moved. Wrong section and also deleted your second thread.
You can post all questions into one thread, we check it. ;)

You cannot downgrade, because of this:

Because the baseband downgrade could result in loss of charm blue note to any previous version after upgrade Flyme 4.5.6A can not downgrade to a previous stable version, please exercise caution!

@AOKP Ok. I will remember that bro. thanks. :)

But is there a way to fix my problem above? without downgrading my Firmware?

last edited by Patrick Paul Pajo Ocampo

@Patrick-Paul-Pajo-Ocampo if I am not mistaken you can also change these settings in the Settings app itself, instead of the navbar.

@AOKP i have a 4G switcher that i download in my Google play… But it doesn’t fix my problem :(…

As you can see from the image below it’s GSM that selected, However in the notification bar it’s 4G… Why is that?

S51025-213045[1].jpg As you


I can change these settings under Settings>Networks>Network Mode.
Here you can select, which mode you want to use.

@AOKP still persistent bro…

Whem i clicked the 3G and 2G it always goes back from 4G. :(…


last edited by Patrick Paul Pajo Ocampo

@AOKP yes i tried to clear data… But i faced the same result… I haven’t tried to reinstall the firmware… If there is how to reinstall?

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.