Google Play Services won't open

Hi everyone.

This forum has helped me a lot. To delete the Chinese apps I had to update the firmware, root the phone and delete the apps. However, I installed Google Play Services from the pre-installed ‘App Centre’ and it won’t open. The screen flashes as if the app is about to open but it never resolves.

Does anyone have any ideas?

What firmware you have and to what version you update…

i have the same case before,
you could try to remove the update of Google Play service and Google Play Store first…
then force stop both service
after that find the Google Play Store from App Centre
make sure its installed completed
And after you have complete install Google Play Store, the Google Play Services should be automatically update according to Google Play Store version you have installed…

Thanks. I figured it out. I installed the Google Installer from the App Centre. After that everything seems fine.

We got 2 M2 Note phones for our daughters.
They were per-installed with Flyme version Flyme OS 4.5.3A
Was not able to install Google apps nor to download anything (USA).
Wrote to Meizu - they were quick and answered:

Dear Sir/Madam,

Thank you for writing to us.

We are deeply sorry for the inconvenience caused.

We suggest that you can try to upgrade firmware Flyme OS 4.5.4A to see whether your problem is solved.

Please click here to download: http://download.meizu.com/Firmware/Flyme/m2_note/4.5.4/cn/20150919190020/029de9f3/update.zip

Before upgrading, please backup your data and follow the instructions as below:

  1. Download the Flyme OS 4.5.4A to your computer and then copy to your phone or download to the phone directly.

  2. Hold Power button with volume up for a while—>Enter into the recovery mode.

  3. Upgrade to Flyme OS 4.5.4A.(please also click clear data!)

Is it OK?

Have a nice day.

Best Regards,

Wing

MEIZU Customer Service Representative

We did that and then we were able to download only from the per-installed app.
Looking online - there are several solutions posted - we tried a few before we came across:
https://meizufans.eu/forum/user/greyghost
He suggests to "Uninstall the google play you installed… Go to meizu appstore and install ‘Google Installer’ by Howie and use that app to install google play properly"
We followed this advice (Search “google Howie” on Meizu AppCenter and this is the first app you get (g on a background of four squares yellow red green and blue from top left to bottom left clockwise).
However we got a server error. Overcame that by following https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0CB4QtwIwAGoVChMI95qovI7VyAIVTDQ-Ch1bNQyr&url=http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3D1IujFpuP3NE&usg=AFQjCNH-fjOma6E8rG_HI7TrntINlRCvaw&sig2=Y_t9fR8WFVovHoHSUD7uGA
Which shows exactly what you need to do.
Restart and turn off automatic updates.
Since yesterday everything works - unfortunately it took us 1-2 hours a day for almost a week to figure all this out.
Seems to be an OK phone for the price without the labor we put in. Not worth it until they come out with a version that actually works in the US (for US costumers). Works with T-mobile plans.
Good luck - hope I made someones life easier and less frustrating and my thanks to all the individuals who shared their experience.

Admin

@hgancz said:

Good luck - hope I made someones life easier and less frustrating and my thanks to all the individuals who shared their experience.

You definitely did. :D

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.