Meizu m2 note - Unable to root, download, install, uninstall, sync, open apps etc...

So I recently received a Meizu m2 note from ebay with 4.5.3A loaded. But the phone that I got is really strange… and I am unable to bypass any of the issues. I was wondering if anybody encountered the same problems. First of all, the phone came preloaded with the playstore, with some bloatware. Now here is the list of problems.

  • The google play store doesn’t download anything. whenever I try to install something, it just infinitely tries to download the app.
  • Flyme account doesn’t sync. It gives me an syncing error all the time. What is weird, is that I didn’t Root the device, the “system privileges” were already Open. But when I checked with Root Checker, it says the phone is not rooted.
  • I am unable to download anything from the browser, JPEG, PDF, etc…
  • I can’t uninstall the Google Playstore, as it only gives me the option to Force Stop. The Meizu App center doesn’t exist on my phone either for me to download it again. I tried installing an APK of it, but it doesn’t open.
  • I tried manually putting Apks though PC/USB, nothing seems to be working properly, and some apps like SuperSu or Super User open and close automatically whenever I click on the icon.
    Basically nothing works… well at least Wi-Fi and the phone service works.
    Can anybody help me at all? is there a solution to all of this?
    I am not quite sure what I can do at this point. I even tried installing something called Google Installer that I found on a forum, which basically let’s you install all the google apps manually, but every time I click on download on any app, it just says “failed to create download link”.
    Any help would be appreciated!

If the phone was prerooted then you have to ask the store you bought it from, to give you the pass to close their account and make yours.
See the post about changing from A to I firmware. Follow the steps by the book and after the update make a hard reset. A firmwares have a lot of problems.

@manik Thanks for replying. Turns out my A firmware was corrupted i realised that after updating to 4.5.4A, and then everything worked fine i was able to follow the A to I tutorial. Now im running the 4.5.4I. Although i gotta ask the Wi-Fi feels slow is it a common problem with this method and phone?

Please help me I am also facing the same problem.
Thanks

Contributor

@kamal19252003 reflash the firmware and clear data.

@Ultrametric - I also have the same problem. But even flashing does not work, as there seems to be a problem with the rooting of my phone. I followed the steps of this tudorial: https://meizufans.eu/forum/topic/2599/guide-how-to-install-i-international-firmware-on-your-chinese-mainland-meizu

But at the final step I could not enter the root-mode after typing “su” in the adb shell. I got the message “[-] Connection to ui timed out”. Does anyone have an idea? I am very frustrated already…

@serjdaher You said, that you flashed a new software. But how did you manage to root your phone? I tried everything already (busybox, SuperSu, RootGenius) but nothing works on my phone. Please help me.

I made it! For all who have serious problems with rooting and flashing - maybe because of an old A-firmware or a corrupt image, check out this threat - https://meizufans.eu/forum/topic/3109/can-t-update-meizu-m2-note/2.

For me everything is fine now and I say THANK YOU to all, who are active in this forum.

Best thing to do is factory reset and then you can install the Google Play Store and Services etc all fresh. That worked for me whenever I had a problem on my Meizu M2 Note that I couldn’t solve. I hope that helps you. God Bless you always. 😇

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.