Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

[Meizu M2 Note] Error installing Google Play via 'google installer' from howie

1

I got my new M2 note a few hours ago however I can’t install the google play services. I tried to install them as soon as I got the phone on the default firmware however it failed to install. As it said installing for a long time and had waiting next to ‘Use Google Play’ (however that was just out of the screen) and after a long time it gave me an error: S51012-161753.jpg .

After which I factory reset and then upgraded to flyme 4.5.4A and tried again however it gave me the same error.

Any help would be much appreciated and thanks in advanced

0

Im facing The same problem…

1

Same problem. Did reset to factory defaults, cleaning and formatting everything. Re-updated 4.5.4A. Nothing works.
Device is great, but I really need Google on it.
Hope anyone knows how to fix it.

1

Hey guys I got the same problem but there is a VERY simple solution that can solve this problem. Ditch the Google installer apk completely. Uninstall it if you already installed it because it does not work on the latest Flyme for some reason…

So what you want to do is open that AppCentre app. Its a blue icon that has like a white half circle in the the blue box.

This is the Chinese “play store” and has what we want. All the apps are served from a Chinese server so it might be slow if you are outside of China. When I downloaded it here in South Africa it was downloading at max 40KB/s so you are going to need so patience ;-)

You are looking for 2 apps that you need to install. Both labelled as Google Play but one is the google settings which enables you to add a google account to you device for syncing contacts,email and calendar and the other one is the actual play store app.

So open AppCentre and at the bottom hit the search and search the term google.

Scroll down and install the app that says Google Play with the puzzle icon and Google Play with the green and reddish Triangle as you see in the screenshot.

S51012-170450.jpg

Now you are done. Restart your device and Google play is working. You can install ALL the google services like photos,gmail,drive,google search,maps and more all via the google play store now.

You can also install all those apps via the Chines Appcenter but I did it via the Play store.

S51012-170459.jpg

0

cavedog, U da man. This problem has been driving me crazy for a week and there must be a hundred people at least that bought the M2 Note side loaded with adware and a faulty Google setup. Meizu asked me to install the official 4.5.4A but was not sure why Google Installer you note above would not work. It just appears to be crap file. Thanks again.

0

@cavedog Worked for me too. Thanks a lot!
Looks like no usage for Google Installer anymore. It’s not clear but it’s obsolete now. They should take it out from the store.

0

I got my m2 today, I am having problems with the playstore, It came already with it, but it is not working (when I tried to download somenthing it just get stuck in downloading), I tried google installer but the same. the problem is that I do not have the chinesse store to download the playstore, I tried to download the newest version 5.9 relased on sep 15, but same. any advice to make it work?

0

@Luis-Arechiga-Salinas First, what ROM do you have? Second, if you go to apps, can you uninstall Play Store? Not just stop, but uninstall.

0

Has anyone loaded a custom recovery on this device as yet? I will be getting this phone today and was wondering if I can just flash GAPPS with TWRP recovery.

0

@Kyle-Hall said:

Has anyone loaded a custom recovery on this device as yet? I will be getting this phone today and was wondering if I can just flash GAPPS with TWRP recovery.

Nope, this is not possible.

3

@zecuria hi. I faced same problem. two days ago I just received my m2 note from japan. Im from Philippines. So in case youre still having that same problem, just downgrade your google installer. When I downloaded google installer , that same picture appeared and as I scroll along the net, I couldnt find a solution. eventhough I in

  • list itemstalled it and the phone would say, google services installed successfully, google play store which is a part of it wont open. well it would launch and load and then will suddenly close. so I searched for older versions of google insallr and you can find it in the appcenter . just click the app google installer , and below there 's a blue “history versions”. click it and downgrade to the last version. that version would have , START INSTALLATION instead of A KEY TO REPAIR and A KEY TO INSTALL. now I have google play store working. i hope this helps.
0
This post is deleted!
0

@Gerline-Mae-Pableo Hi Gerline Could you please be more precise and specify which Nr. Version of google installer did the trick ? Also It would be interesting to know which Flyme version are you using.

Thanks from Spain

0
This post is deleted!
1

Hi All Meizu Fans Members
This way is OK.
For Fix Google Play Service Prolem with Last version flyme, First You must Download and install last version of Google play Service ( matching with your cpu version ) then download Older and full Version of Google installer in app cnter with 30mb size. ( if you accuracy in history of google installer in app center last 2 version have low Size 2 or 3 mb but older version is 30 MB. )
Finnaly Run google installer and click install and wait instalation complete. ( its very fast )
Now You can Create Google account and use google service.
ByE.

Log in to reply

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.