4.5.6A Google Play Store/Services

Hi Meizu MX4 users,

Since I updated from 4.2.8U to 4.5.6A I noticed my Google Play store and services don’t work anymore. So I tried to remove the whole Google Services from the phone and installing it by using the App Center from Meizu itself. No results! :(

Now: when I open it, it flashes and it closes. I think its a known problem.
Anyone have a quickfix for it or do I have to reinstall my phone and clear data?

Thanks in advance.
Have a good weekend!

Bas

Add:

I tried to install the Play Store and Play Services via AppCenter
I also tried to install the “Google Installer” via AppCenter but that app kept saying: “Waiting download” and after that: “File damaged”.

Download google play service.apk latest version and Google Play latest version .apk

Did you upgrade with clear data on? I assume not since your Google Play store was still there. Well, you will have to reflash it, upgrade to 4.5 (lollipop) requires that.

Yes I didnt select clear data. -Stupid, because I knew I had to select that.- However, when Im trying to reinstall the 4.5 update WITH clear data selected, still cant install the Play Services etc. What do you mean by “Reflash”?

last edited by Basho

I mean: Just try to install the update again. Well, you will have to look for the Google Installer, installing Google services directly does not work. You can find it in the Meizu App Market.

last edited by Kokkie

OK: so basicly:

  1. Try to reinstall the update 4.5.6A
  2. Wipe data when asked
  3. Use the Google Installer for the Play Services etc. listed in AppCenter

Im downloading it from: http://www.flyme.cn/firmwarelist-6.html
Because of the “A” version.

last edited by Basho

The Google Installer keeps saying “Wating dow…” at the “Use Google Play” part. I need my phone and now its stuck -_-.
It gives me this status 10 minutes already

//
I set it back to 4.2.8, the A versions should have play store normally

last edited by Basho

Experiencing the exact same problem

Phone: Mx4
Firmware: 4.5.6A

The google installer from the Meizu app store (file data 10/10) starts but then hangs with “File Damaged”

Brs
jokke009

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.