MX4 PRo Bricked?

my meizu MX4pro stack on meizu logo .
i can go on recovery mode (power+volume up) but i cant copy file(update.zip) inside phone

i can go on fastboot mode(power+volume down) but i cant use any funtion on ADB reconized as android 1.0

Please help me
My phone is completely bricked?
Thx

Yep, I am sorry to tell you. Things like fastboot come at a risk at Meizu phones. I never tried such things myself, so I don’t know exactly what you did. But unfortunately there is no solution afaik.

I don’t know if in recovery there’s such possibility…
Can you try to load update.zip through Usb Pen drive by an Otg cable?

Admin

@MrBrown94 never tried it, but I do not think it is possible either. What you can do though is to connect the phone over USB to your PC, while it is in the recovery. It then opens an extra partition where you can put the update file.

if you know some friend with an otg cable … try it and cross fingers

I used otg connect over flashdrive don’t work
can connect PC while it is in the recovery .It have recovery drive 1.X GB
can copy update into it but can’t upgrade

edit i retry 2 times.at last time i copy and don’t unplug usb after copy finish push upgrade can upgrade

sorry for my english

last edited by gurokz

Fastboot on MX4 Pro works like other manufacturers - since it’s samsung :)
The only thing you can do: fastboot flash recovery
BTW, maybe you are on linux? You can mount /dev/sdx and pass firmware to the recovery. Unmount before starting flash.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.