Lots of issues after upgrading to 4.5.4I

Hi!
I’ve bought a M2 note in Israel two months ago. As I got it, it had a minor bug, where the calendars cloned themselves constantly, till every calendar (in every application on the phone) was showing 50+ times, and it became crazy, so I decided to contact the Meizu support team.

At that moment I had firmware version 4.5.1I, and although version 4.5.4 was already out, my phone was showing that I have the latest version available. Then the girl from the support told me, that I should download the latest firmware from the website and upgrade it.

Since I’ve done it, Google Play doesn’t open (so I can’t upgrade or install any app :(! ), I don’t have a GPS, I don’t have location tracking (so I can’t use any of my navigation or fitness apps :disappointed: ) , many words appear in Chinese and the Google Now command “OK google” doesn’t work although it’s turned on :(

I don’t know how to revert to the previous version, and I’m not even sure now whether the previous version I had wasn’t localised specifically for Israel (does it even exist??). Right now I really don’t have a clue what to do, since I don’t know how to flash the previous firmware to the phone (I have a macbook and no other PC available).

If you have an idea for a solution I will be so so grateful :pensive:
Thank you!

Admin

First of all, no worries.
Downgrading and upgrading is the same procedure.

Basically our F.A.Q. should be able to help you:
https://meizufans.eu/f-a-q

However, do not forget to select the “Clear Data” option. This will wipe all apps and custom settings, so be sure to have a backup.

Hi! Thank you!
If I try to do that with an older version of the firmware, I get the message “Firmware Corrupt”. I tried 4.5.1 and 4.5.2 downloaded from here.

yes, same issue i am facing after the latest update .it is hanging a lot.multitasking lagging so much, that i cant use social media apps simultaneously.

Please Meizu development team release a patch for fixing issues :unamused :

ok, so I managed to install 4.5.3I and then, I uninstalled and installed the google installer, and then installed again google play services & store. Right now, I can’t sync my contacts and the calendar, so I have no contacts. :expressionless: What should I try now?

Thanks :pensive:

Meizu m2 note

אהלן ;)
I understood that do a factory reset fixes the google’s problems in 4.5.4, so I guess it’d also fix it on 4.5.3. try it and update me

about the GPS, I had the problem also (on 4.5.3), then went to Bug where I bought it and they saw that something in the settings wasn’t on

LOL, in the end I just got hysterical and I installed and uninstalled Google play services like 1000 times, AND IT WORKED, when I finally gave system privileges to the Google Installer.
So sometimes freaking out and abusing the phone DOES work :smile:

Meizu m2 note

@irisrashap haha well if it works then it’s okay ;)
just to know - how do you install/uninstall google services?

I also facing same issue after latest update 4.5.4I . after that in my mobile google play store not working .

Same here with original installation of 4.5.3A. All downloads disabled. I think you are on track with the “permissions” issue. What did you change there? I have already asked Meizu how to remove Google services so I can do a reinstall but they have not answered after a few days.

Admin

@caseymarie currently there should be national holidays in China, if I am not mistaken.

Anyway, if clearing data and a firmware upgrade do not help you’ll have to deal with it.
Sad but true.

@AOKP Thank you. I have tried to install new firmware but as the M2 will not download, I downloaded to my PC. I went to transfer it over usb to the root directory but the system will not let me do it. That’s kind of strange because I was able to transfer over Google APK’s. Do you think the problem is that the firmware is a zip file?

Admin

@caseymarie nope. It could be a simple problem related to the USB drivers, the USB cable or the phone itself.
Maybe try it again over a different USB port on your PC.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.