M2 - help, cannot add a Google account

Hi, I just received a Meizu m2 (regular, not note). It has Google installed, but doesn’t let me add a Google account (No dialog after I choose Google as the added account, it immediately returns back to the Accounts page in Settings). Also Google Play doesn’t start (opens and closes immediately).
Any suggestions before I send it back and never buy Meizu again…?
Thanks for any help

Hi friend.Shut down the phone.With power and volume+ go to recovery menu and check only clear data.After five minutes the phone boots and after go to app center and on searching bar write google installer.Download google installer and install google services and google play and after that works.

Well, make sure you install the Google services correctly, take a look in the FAQ on the main meizufans site.

last edited by Kokkie

Yes, I had same problem. Unistall google play and whatever you have installed regarding google, after clearing data in each of the above application. Restart the phone and install “Google installator” from app centre, and it will install all necessary apps. You have probably install Google play itself directly right?

Thanks everyone!!!

  1. I received the phone (from AliExpress) with Google play already installed - probably a bad installation…
  2. The seller probably fiddled with the ROM, as Google play is on the system partition, so I cannot uninstall it as a regular app, I’d need root permission, which by the way I cannot get, and its a different story…
  3. I don’t have Meisu app center installed (the seller probably removed it…)
  4. I downloaded a google installer for Meizu, but when it runs it says that Google already installed, and then exits…

On top of that I contacted the seller, and they said they have a vacation now, and I should contact them next week…

Regarding the root - I logged into my FlymeOS account, and the priviledge says OPENED, but when I copy RootChecker to the phone and install it (using Documents app) - it says the phone is not rooted - so I cannot uninstall the bad Google Play from the system partition…
What a mess… Can you still give me an advice ? I tried to look for a firmware for m2 (not m2 note) so I could flash over the seller’s messed up firmware - but couldn’t find any, can you help me with that?
Thanks for any help,

Oh I forgot, I also tried clear data from the Recovery menu (I managed to get ADB connected, and I type ADB reboot revovery), but that didn’t help, I also tried clear cache/data on Google Play Services and on Google Play Store but that didn’t help either.
What partially helped, was installing a recent google Play Services apk (as an update), which allowed me to add a Google account, but I still couldn’t install any app from the store (it hang on “Downloading” phase, no matter how much time I waited), I even downloaded a recent Play Store app too, also didn;t help

Again, what a mess. I bought several Jiayu S3 for my family, not a single issue, everything went smooth…
I hope I manage to solve this, the phone itself looks nice, but useless…

Admin

Reinstall your firmware with “Clear Data” then.

Check the F.A.Q. for more, it contains a pictured guide:
https://meizufans.eu/f-a-q

also, when obtaining root you may also install a super user app (I have chainfire’s SuperSU) because some root applications like Titanium Backup require it to work effectivelly

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.