No Service / No Simcard when on Mobile Data

Running on 4.5.5A (rooted)

I experience the following problem: Suddenly, the phone starts disconnecting from the Tower Cell as soon as I turn off the Wifi (with Mobile Data enabled). If Mobile Data is disabled, the connection is stable.
This is the second time I have this issue. Last time I did a factory reset, and it has been working ever since - up till now.

This time, I have tried the following to figure out where/what the problem is:

  • Tested with different Mobile Data speeds (only 2G, 3G first and so on). It makes no difference.
  • As long as WiFi is on, the connection is stable both with and without Mobile Data enabled
  • But when Wifi is off and Mobile Data is switched on, the phone loses connection with the Tower Cell - and switches between connecting and disconnecting whilst the following statuses is shown No Service / No Simcard / #Operator name#
  • Just for testing, the APNs have been deleted and typed back in. It did not change anything
  • I have also reflashed the phone with the same Firmware, but the issue remains.

Finally, I have now done a new Factory Reset, and the issue is fortunately gone (again). But for how long?

In my opinion, this is apparently a soft-/firmware issue. Any hardware faults is persistant, and will not disappear by doing a Factory Reset.

It is not especially nice to have a phone that must have a Factory Reset every couple of weeks… does anyone got an idea what this might be?

Admin

Try the latest stable firmware 4.5.6A and see if you still encounter these issues.

Updated to 4.5.6A today. Phone worked fine for a few hours, but the same problem is back now. I have also replaced my SIM-card today, but it didn’t change anything.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.