Can not place or receive calls with 3G or 4G Data enabled.

Hello guys. I am using a Meizu MX5 with 4.5.2.7A firmware. My carrier is Orange Romania and I have a problem.

Whenever I activate my data, especially 4G after about 30-45 minutes or so I cannot make/receive a phone call. When I try to place a call the phone sits in the dialing screen without any response, and when I try to call my phone it says that the client cannot be reached. The other functions of the phone work just fine during this time.

To resolve this issue I have to turn the mobile data off and wait for about 15 minutes, or reset the device.

It’s really frustrating when a device this powerful has these kinds of issues and it’s not just my phone. I bought one for my father too and after I tried to activate data on his device, surely the same thing happened.

Has anyone else experienced anything like this and can you point me towards a solution ?

Thank you in advance !

last edited by Ultrametric
Contributor

Mod edit: moved the topic

So your 3G and 4G internet works, but you can’t receive calls, this is it?
The 3G and 4G bands of your provider are supported, so this can’t be the problem.

Do you use both sim-card slots? If only one, do you have the sim card in the primary one?

But you do have a time-gap of up to 45 minutes where the phone is able handle outgoing and incoming phone calls?

How is your connection on the phone in general and when you turn of 3G or 4G?

Do you think it could possibly be an issue of the Contact-App?

What did you do with your phone so far, did you root it and remove some system apps?

last edited by Ultrametric

@Ultrametric Hello and thank you for moving the topic to the right place…

When I tried to create the topic I was in the Meizu MX5 section, Q&A subsection. I must have done something wrong.

Just call orange. It’s most likely carrier related. i’m on telekom and when on 4g i cannot send/receive sms’s

Contributor

it could also be that the sim-card you are using is too old. There are a lot of possible solutions to this problem :P

@Ultrametric said:

So your 3G and 4G internet works, but you can’t receive calls, this is it?
The 3G and 4G bands of your provider are supported, so this can’t be the problem.

Do you use both sim-card slots? If only one, do you have the sim card in the primary one?

But you do have a time-gap of up to 45 minutes where the phone is able handle outgoing and incoming phone calls?

How is your connection on the phone in general and when you turn of 3G or 4G?

Do you think it could possibly be an issue of the Contact-App?

What did you do with your phone so far, did you root it and remove some system apps?

  1. Yes, that’s the problem.
  2. I use both SIM slots, but my primary is the one on which I use the internet. When data is active and I cannot be called on my primary SIM, my secondary SIM works just fine.
  3. Yes. After I turn on data, there is a window in which both the phone and the data work fine, although this window of time varies to some extent. Sometimes it’s 10 minutes, sometimes 40…
  4. The connection on 4G is very good. Getting 40 Mbits Up/Down (at least I think it’s good).
  5. I don’t think it’s because of the contacts app. When I try to call myself it says that the caller cannot be reached. Almost as if I am disconnected from the network, but the data during this time works just fine (and I’m getting a good signal)
  6. I did not root the phone and I can’t think of any system apps that I have deleted.

Also I want to mention that the sim card is brand new, I had it changed when I received the phone as I did not have a nano-sim card before.

Contributor

@VladGorgan okay thank you for the provided information.

If you have two sim-cards from a different provider. You could swap them and try to replicate the problem.
If the same problem occurs with two different sim-cards from two different providers, it’s very likely that the phone or a setting on the phone is the problem.

In general the default recommendation is always to wipe all data (after you do a backup of your data) and do a clean Firmware upgrade.

Hello again !

Well after a few days with “testing” it appears that (with your help) I have solved the problem.

When you use two SIM cards on your phone, it would be best if the main SIM (voice + data) would be used in the SIM 2 slot because the problems did not appear again. The 1’st SIM slot appears to be able only to handle calls, without data, at the same time. A bit weird if you ask me, but hey…

I was able to keep my data on for days and could place calls or send SMS just fine without any trouble. Swapped SIM cards in my father’s phone also, and the problem disappeared.

Thanks guys for the help !

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.