MX5 not working on 3G networks

i bought MX5 in china but now when got back to Israel i have only 2G networks. when was in China, i had 3G and LTE.
can it be that Mizue is selling models that are not suitable in terms of netwroks?

Admin

You need to check the LTE bands of the phone and the ones from your provider.
However, as far as I know most israeli providers cover the bands, therefor check your APN settings as well.

the LTE bands worked when I was in china
APN settings where checked and reconfigured again and again.
the only thing i can think about is that the ver. flyme 4.5.2.4C is disabling the LTE network…
any other idea?

last edited by giladbi
Meizu Pro 6

I believe someone else also had LTE problems with the C firmware. After flashing the A firmware LTE was working. Maybe try that.

last edited by generationally
Meizu MX5

You need to install the version A of the firmware, for many users that was the problem.

Meizu MX5

@giladbi said:

how do i do install A version?

Download update.zip from http://downloads.meizufans.eu/mx5/firmware/stable/4.5.2.4/a/update.zip
Put that file in the root folder of your phone, then open the “Documents” app (it is the meizu’s file manager app), find the update.zip and tap on it, that easy :)

(P.S. You won’t lose app/data)

last edited by Antowitz

Ok found it and installed
it’s working!
thanks

Meizu MX5

@giladbi said:

Ok found it and installed
it’s working!
thanks

Glad to hear that :)

hope this works for me im in uk with version c and same issues no signal at all

@Antowitz Thank you! Worked perfectly for me!

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.