Microphone problem

Hey guys
I just bought the meizu mx4 pro 2 days ago and i noticed that the mic doesn’t work.
First it was with the camera; when I try recording a video, all i get is static noise / no noise at all.

Then, when someone calls, he can’t hear me most of the times (sometimes the mic itself works and they can hear me). But when I use the speaker whiel calling someone, the microphone works…

I can’t even record anything on the Recorder app.

Do you think it’s a hardware problem or a software?

help me :(

@‘mynameiskyx’ said:

Hey guys
I just bought the meizu mx4 pro 2 days ago and i noticed that the mic doesn’t work.
First it was with the camera; when I try recording a video, all i get is static noise / no noise at all.

Then, when someone calls, he can’t hear me most of the times (sometimes the mic itself works and they can hear me). But when I use the speaker whiel calling someone, the microphone works…

I can’t even record anything on the Recorder app.

Do you think it’s a hardware problem or a software?

help me :(

I guess hardware, but we need to know:

  • on which firmware version you are
  • did you flash the newest / reflash it?

If you checked this and this doesn’t work, I would send it back as DOA to your supplier.

I’m using Flyme version:Flyme OS 4.2.8.2A
What do you mean flash/reflash?

@‘mynameiskyx’ said:

I’m using Flyme version:Flyme OS 4.2.8.2A
What do you mean flash/reflash?

Some bugs arise out of blue during flashing of the firmware. Sometimes flash it again and the bug is gone, apparently. But I guess that this one is hardware related.

Hi guys,
I reflashed my Meizu M2 mini and now microphone not work, if reset the phone (factory reset) mic work for some minutes and after begin again not work.

Please can you help me.

Thanks

last edited by mofabio

Hi Fabio.
Where you able to fix your problem? I’m facing the same and I’m about to return it to saler…
Any tips would help!

Thanks!
Flávia

Hello guys,

I have the same problem! I bought my Meizu on Aliexpress in the Black Friday. Yesterday I recived it and noticed thant the main mic doesn’t work! I have the same problem of @mynameiskyx. How have you fixed it? I have the Meizu MX4 Pro with Flyme OS 4.5.4A. The updater says that this is the las version.

I’m also about to return the phone to China, but this option frightens me a lot.

In adition I’ve seen that the fingerprint scaner don’t work, also with the “back button” (home button + swipping finger upwards).

Any tips will be wellcome

Admin

4.5.4A is NOT the latest stable firmware. Check our archive and flash the firmware as shown in our F.A.Q. then see if the problem still exists.

@Rey Hi Rey!

I was thinking on it, but the warranty will be lost if I reflash another Flyme version isn’t it? The Flyme built in autoupdater told me that there are no newer updates for the 4.5 version. I opened a dispute with the seller asking just for that. If the seller tell me that warranty will not be avoid with the reflash, I’m gonna try another Flyme version.

Wich one could you recomend me? (mx4 pro, 16GB)

Thank you for your answer!

PD: I’ve installed the 4.5.7.1A version and the problem persist. The micro is dead and the fingerprint reader don’t work. If I can’t find any other solution I’m gonna send it back to China :disappointed:

Ideas?

Thanks

last edited by arrakeeen

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.