Battery Drain - uknown wakelock

Hi everyone,
I’ve a problem with my MX4 battery. I can use it only 2 hours (screen on time) in a day. I post here the screenshot from betterbatterystats.
I hope that someone can help me because EINT, CCCI0_peer and ttyC0 wakelock are killing my battery :(
Thanks,
Cristiano


I’m sorry this is the app called gsam battery monitor and not betterbatterystats :)

Meizu Pro 6

I have also had issues with these wake locks. They have basically kept my phone awake 15-25% of the time. Now I’m seeing 5-8% awake time.

After googling (some Chinese sites) I learned that the culprit is the EINT wake lock and that it is related to the wifi chip not being put properly into sleep mode. So one solution is to make sure that your wifi gets automatically turned off when you don’t need it.

I’m using the Xposed module ‘Smart Network’ so that my wifi is turned off whenever my screen is turned off. The module ensures that wifi turns on again whenever my screen turns on. That way I have my wifi connection on when I’m actively using the phone and have the wifi off when I’m not actively using the phone. This has improved my wake lock situation significantly.

One simple way to try if this solution will work for you is to turn your wifi completely off for a day and then check your wake lock statistics after that. If this test improves your wake lock statistics then you might want to go ahead and try the solution mentioned above.

If you don’t want to use the Xposed module then there is also a ‘normal’ app that can do the same thing. I don’t recall what it is called but I used that for some time until I found the Xposed module.

You don’t need an app or a module for that, this option is built in in the Android settings.
Settings - wifi - more - advanced - tick the second option.

Meizu Pro 6

Yes, I know about that option and I always have it on.

But the problem is that there is some issue/bug with the MediaTek wifi chipset which prevents the HW to go to sleep even if that option is chosen.

That is why the Xposed module is useful. It forces the wifi off. It is a work around for the bug.

what kind of module they take their?

But if the wifi is off, how f.e. will you receive msgs from Viber/WhatsApp?
That’s the only reason I have not used that option, since WhatsApp is very important for me in my everyday phone usage.

I don’t think that my wakelock is correlated with wifi. I have battery drain also when i leave the wifi off :(
Thanks for the answer :)

Meizu Pro 6

@‘Miko’ said:

But if the wifi is off, how f.e. will you receive msgs from Viber/WhatsApp?
That’s the only reason I have not used that option, since WhatsApp is very important for me in my everyday phone usage.

You will still get your notifications. The phone will just be using the cellular connection (2G, 3G, 4G) instead of the wifi connection if the screen is off.


@‘crisava’ said:

I don’t think that my wakelock is correlated with wifi. I have battery drain also when i leave the wifi off :(
Thanks for the answer :)

Too bad it didn’t help you. Let us know if you find a solution.

We are all looking for ways to improve our battery life!

@‘generationally’ said:

@‘Miko’ said:

But if the wifi is off, how f.e. will you receive msgs from Viber/WhatsApp?
That’s the only reason I have not used that option, since WhatsApp is very important for me in my everyday phone usage.

You will still get your notifications. The phone will just be using the cellular connection (2G, 3G, 4G) instead of the wifi connection if the screen is off.


Usually when I have the wifi on (home or cafeteria) i turn off the data… never have both of them on.

Mod note: Locked topic, topic is too old.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.