Baseband 425

Do I need this http://meizufans.eu/forum/thread-02-1248-00-r09-425-official-wcdma-baseband for Flyme 3.5.1A?
And what version? I have MX2 HK (baseband 02.1201.01.-248) but with Flyme 3.5.1A CN firmware.

Thanks in advance!

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.