USB to PC error

Hi, I bought MX4 few days ago and whenever I connect it to PC, I can’t copy files, because I always get error that Meizu MX4 has been disconnected or stopped responding… I have windows 7 64 bit.

Ok, after many reinstalls it worked.

Silly question but you have USB debugging option on, right?

Tried with and without debugging. Now I have this option off.

Do you have installed newest Windows Media Player?
I had connection problem with PC by USB and that installation have solved all errors.

Thanks for all your support, but as I mentioned in my edited first post, it worked after many reinstalls. Thanks once again ;)

afyer many reinstall of what i try also many reinstall and don’t work

Of drivers. In control panel I uninstalled the MX4, computer restart, then plugged the device and finally it’s working fine. It worked after few times.

Deleting Meizu MX4 for device manager, then restarting the PC, then reconnecting the device DID solve this bug for me.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.