How to install A version coming from I version?

Hello!

I have the 4.0.4.1I version (updated it OTA) and I would like to switch to Chinese version (A)

I try to install the 4.1.6A, when I press INSTALL, it goes to Checking Firmware, it says, Firmware corrupt.

Any idea?

Thanks
David

@‘Opdavid’ said:

Hello!

I have the 4.0.4.1I version (updated it OTA) and I would like to switch to Chinese version (A)

I try to install the 4.1.6A, when I press INSTALL, it goes to Checking Firmware, it says, Firmware corrupt.

Any idea?

Thanks
David

Try downloading again.
Also check the md5 checksum.
They should match

First downgrade to some older version for example 4.0.3I and then try to install 4.1.6A. It should work this way, someone had same problem.

Hello you have got problem like me. I found the way to fix it:

http://meizufans.eu/forum/thread-firmware-corrupt–1108

Can please somebody tell me what’s so special and unique about flyme4 on mx4? Please

I think the file I’ve downloaded was faulty. I went back to 4.0.4.1A from 4.0.4.1I with no problem.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.