Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

  • USB debugging


    I enabled usb debugging in the settings but it doesn’t work (eclipse cannot detect it).
    Windows says that driver not found.
    but i can use usb MTP to transfer files.

  • In the MTP Menu, choose Virtual Cd Rom.

    Windows will mount your meizu as Cd rom with the good drivers in it.

    But, on my pc, the connection don’t work fine with my Windows 8.1 64 bits.

    I must use an another PC with Windows 7 32 bits to use adb drivers.

  • thanks for your reply.
    However, it didn’t work on my 64bit window 7.

    i have 64bit window 8.1 at home, i will try it tonight

  • @mongolshooter,
    Check if manually running “adb devices” from terminal shows the device…

    Meizu MX3 32GB HK edition.
    If someone helps you use the Like/Thanks button :)

  • @‘GreyGhost’ said:

    @mongolshooter,
    Check if manually running “adb devices” from terminal shows the device…

    List of devices attached shows nothing on my window 7 64 bit

  • It is quite possible that it works only on 32-bit version :(

    On my Windows 8.1 64 Bits, it didn’t work

    On my Windows 7 32 Bits, it works very well.

    Maybe, adb works only on 32 bits computer with the Meizu MX4 Pro :S

  • @Smoi,
    It is all about the drivers… If the drivers are correct it will work on 64bit too… Windows 7 atleast… Windows 8 has been a mess for quite a lot of people…

    Meizu MX3 32GB HK edition.
    If someone helps you use the Like/Thanks button :)

  • Sad i tried my device on Window 7 64 bit
    window 8 both 32 and 64 bit, none of them works

    :((((

  • sad how to install those driver

  • Very strange. For me stuff like that works.

  • @‘AOKP’ said:

    Very strange. For me stuff like that works.

    what window version do you use?

    Besides, whenever i plug my device to the usb, the device prompt me for password, is this normal?
    Even i do not enter the password, i can still use mtp to transfer file.

  • Retested on my Window 7 64 bit, it works now!!!
    ( I forget to add 0x2a45 to adb__usb.ini)

    But window 8 does not work
    sad because i use window 8 at home

  • I use Win 8.1 Pro.

  • Hi everyone.
    I just would like to share a solution which worked for me about USB debugging :

    1. Enable USB debugging from Settings > Accessibility > Developer options

    2. On the PC, open Device manager (right click on This PC >Manage > Device Manager)

    3. Under Other devices, you’ll see _MX4… (_with yellow triangle containing an exclamation mark).
      Right click on it > _Update Driver Software > Browse my computer for driver software > Let me pick from a list of device drivers on my computer > _search/select _Samsung Android ADB Interface > _click _Yes _when _Update Driver Warning _message box appears

    Note : notice if you develop Android Applications using Android Studio, make sure minimum sdk version defined in “your project”/app/build.gradle file (“minSdkVersion XX”. XX is the version number) is under your MX4 API’s version.

    I just put it to 10 while my MX4 API’s version was 19.

  • Solution by Rolm solved it for me on Win 8.1. Pro 64-bit.

    The drivers supplied by Meizu directly from the device when changing Storage mode to CD-ROM does NOT work. The Google USB driver doesn’t work with the MX-4 either, it does however, work with my Nexus 7 though.

Posts 17Views 8319
Log in to reply

Looks like your connection to USB debugging was lost, please wait while we try to reconnect.